News

Improved security websites Disable TLS 1.0 and 1.1

In the coming weeks, LISA will improve the security when you access the university's web servers.

Traffic between web servers and your computer or mobile device is always encrypted. We call this method of encryption TLS. The way in which this encryption takes place is continuously improved. The encryption methods have version numbers such as TLS 1.0, TLS 1.2 or TLS 1.3. If we continue to use old encryption methods from before TLS 1.2, we run the risk of an attacker finding out the contents of the traffic between your device and the web server. This is therefore not safe and that is why we disable old methods. As a result, some devices that do not support the new methods, no longer work with these websites. This can be the case with a mobile phone or notebook that has not been updated with the latest updates.

You will wonder why the UT is implementing these updates: According to the GDPR, we are obliged to implement adequate security when processing personal data. The 'Nationaal Cyber ​Security Centrum' (NCSC) has indicated that only the latest versions, known under the names TLS 1.2 and TLS 1.3, are good enough for this.

If you can no longer connect to secure websites with your device, try to install all updates first. If this still does not work, it is likely that the device is too old. Please contact Servicedesk ICT if you have any questions.